Warning: Jailbreakers Should Wait Before Updating to iOS 8.1.3

Warning: Jailbreakers Should Wait Before Updating to iOS 8.1.3

Posted by · 10952 views · Translate
Apple has just released iOS 8.1.3 and currently there is no word on whether or not it patches the iOS 8.1.x jailbreak.

We will update this page and let iClarified readers know once we receive confirmation on whether or not the update patches the jailbreak. In the meantime, we recommend staying on your current firmware. If you are on a lower firmware and want an iOS 8 jailbreak, now is your time to restore to iOS 8.1.2 before Apple closes the signing window.

Please follow iClarified on Twitter, Facebook, Google+, or RSS for updates.

Update: Apple has blocked the TaiG Jailbreak, meaning users cannot jailbreak iOS 8.1.3

Warning: Jailbreakers Should Wait Before Updating to iOS 8.1.3
SS642 - January 28, 2015 at 3:35am
It's a really good thing that Apple is getting rid of the illegal jailbreaks. Everyone should update now, no matter if your illegal hack doesn't work. BTW, if you want to hack stuff like that, you should go back to using android.
really - January 28, 2015 at 6:31pm
Actually jailbreaking isn't illegal, its perfectly legal to jailbreak your device. You've paid for it, you have the right to do whatever you want with it. Now apple doesn't have to cover anything during warranty if it's jailbroken cause they have that right too, but jailbreaking isn't illegal, get your facts right.
Gürk - January 29, 2015 at 5:44pm
Well as said. You do whatever you like with your IP. Jailbreak is great for us who like to tweak.
iCluelessfied - January 27, 2015 at 11:47pm
Anyone know why my jailbreak on 8.1.3 stopped working? I just updated to the latest version, but it erased everything, including my jailbreak. How do I jailbreak 8.1.3? Please help. This is complete crap that there was no warning before updating to this version! iClarified, this is your fault! You should warn the users to not update!
A Previous Jailbreaksr - January 28, 2015 at 4:19am
Icluelessfied fits for you as your a jerk and most likely only posted this to get a response from others and you either don't really jailbreak or your really still on 8.1.2 Everyone knows not to update if your jail broken or you live under a rock. What a complete a..hole you are
1 More Comment
Recent