Amazon Prime Video is Finally Available on the Apple TV

Amazon Prime Video is Finally Available on the Apple TV

Posted by · 10 comments · Add Comment
aahhgeezz - December 6, 2017 at 6:01pm
A simple no no problem here would have been enough! You do not need to be an prick!
Kornmehl - December 6, 2017 at 6:06pm
Yes, in fact I do need to be a prick. The idea is to get lame-brained morons off of this site. Then we will only have useful comments here, not stupid complaints from newbies.
Joseph - December 6, 2017 at 9:41pm
You are the prick here sir.
Pauliep - December 7, 2017 at 2:14am
Yes sir, you are a prick
aahhgeezz - December 6, 2017 at 5:38pm
Am I the only person by chance that no videos load? Installed the app on my original Apple TV 4, signed in and all that. I see and can search thru all the sections, etc. no videos will load at all. Not kids shows or movies. I just get the spinning Apple animation thing. Every other app on the Apple TV works fine and fast, netflix for example shows load and start playing with no issues. Rebooted the damn thing, still no go! Anyone else having this issue?
Kornmehl - December 6, 2017 at 5:49pm
Yep, just you, turdbrain. It's working fine here down under. You can go to your local Apple Store; they have some beginning classes on how to use a computer (and an Apple TV).
botzy - December 6, 2017 at 9:06pm
I also have a problem on my Apple TV 4K. Ultra HD videos won’t start. I get a spining circle like it’s buffering but no image, just a black screen. I have a gigabit lan on a gigabit router. Reinstalled but it’s the same. Regular videos work just fine.
aahhgeezz - December 6, 2017 at 9:13pm
Well I did figure out the issue finally even though Kornmehl was an a-hole and just trolling people. However, botzy, I forced tried to fast forward any video I tried to play and FINALLY it gave a message to the screen. Gave the good old "This video can't be played. It looks liker your HDMI cable or connection doesn't support HDCP, which is required to play this type of video. Try reconnecting the HDMI cable from Apple TV to your TV, and play this video again." Message. SO I switched HDMI ports and Cable and it worked instantly! Give that a try, hope it works for you.
botzy - December 7, 2017 at 2:06pm
The cable is not the problem in my case. I use Netflix on the Apple TV 4K and there’s no problem with the video signal. Also Vimeo plays just fine any 4K video from their site. I’ll try uninstalling and reinstalling it as soon as I get back home. Anyway, hope to solve this eventually. Glad yours works.
Botzy - December 7, 2017 at 5:56pm
My bad. You were right. Changed the HDMI port from the 10bit one to the one marked HDCP 2.2. Looks like the pussydownunder was wrong about you. Your advice helped someone.
Prev1 of 1Next