Apple Stops Signing iOS 10.3.1, Downgrades and Restores No Longer Possible

Apple Stops Signing iOS 10.3.1, Downgrades and Restores No Longer Possible

Posted by · 4604 views · Translate
Apple has stopped signing iOS 10.3.1 which means that downgrading or restoring to that firmware version is no longer possible.

Currently, Apple's latest firmware is iOS 10.3.2 and developers have been seeded with iOS 11. If you accidentally update or restore, you'll find yourself on iOS 10.3.2.

While Pangu demonstrated a jailbreak of iOS 10.3.1 that worked on the iPhone 7 it was never released. Just last week a jailbreak of iOS 11 beta was demonstrated by KeenLab; however, it's unclear if the group plans to publicly release the jailbreak or whether it will even work on the final version of iOS 11.

Please follow iClarified on Twitter, Facebook, Google+, or RSS for updates.


Apple Stops Signing iOS 10.3.1, Downgrades and Restores No Longer Possible
tuffigirl - June 28, 2017 at 4:29pm
I can downgrade anytime I want...only dummies who didn't save their blobs can't downgrade.
Neolm09 - June 29, 2017 at 12:48am
Wow, you should take tim cook's place.
Pyrocynical - June 28, 2017 at 2:12pm
Jailbreaking iPhones in 2017 is pretty much dead.
@everyone - June 28, 2017 at 7:46am
Article Translation: Basically....if you upgrade...you'll find yourself upgraded...and you may/may not be able to jailbreak on ios 10.3.1 if the tool is released, which will not happen most likely... Because you may/may not be able to jailbreak on ios 11 when it comes out because that may not/may be released ...so basically...go ahead and upgrade/don't upgrade....but be careful because a tool may/may not be released....maybe....so go ahead and upgrade but these guys at this event showed a tool that jailbreaks the operating system that you are currently on but most likely wont be released because of ios11/bounty issues. maybe just go ahead and buy an android or buy an iphone on 9.0.2 or lower and be done with it. Sincerely iClarified....
Neolm09 - June 28, 2017 at 1:03pm
Good translation, You're just missing one piece, "you may/may not saved you're shsh blobs so you may/may not be able to downgrade using a downgrade tool which may/may not be released"
2 More Comments
Recent