How to Unlock/Jailbreak Your iPhone 2G on OS 3.0.x Using RedSn0w (Mac)

How to Unlock/Jailbreak Your iPhone 2G on OS 3.0.x Using RedSn0w (Mac)

Posted by · 113 comments · Add Comment
On-Wax - August 21, 2009 at 2:26am
I have the IPhone 3GS with 3.0.1 firmware, when i tried to restore the phone using \"iPhone1,1_3.0.1_7A400_Restore.ipsw\" it gave me an error message that said \"the IPhone... could not be restored because the firmware file is not compatible\" Any ideas??? Please???
dtown218 - September 12, 2009 at 1:16am
read the tut! this is for a iPhone 2g not and iPhone 3g like you say u have. duh..
ReliableSource101 - August 20, 2009 at 12:40am
Thanks For the Info it worked great for my iphone 2g I\'ll be sure to return to this site for any other information needs. Keep up the good work!
MrBlue - August 11, 2009 at 7:02pm
Hello, my 2G was succesfully upgraded to 3.0.1. the only problem is phone call sound became vibrate only. No ringtone. How can I solve it? thanx
pmb - August 9, 2009 at 9:26am
These tutorials I find seem to only work for the *iPhones* and not the iPod Touch as claimed to do? Would like to hear from an iPod Touch 2G owner that got theirs to work. No matter which firmware version I tried after all the suggestions across the \'net, it never worked with my iPod Touch 2G (v.3.0). Hangs on the \"reboot\" message every time. Bah. Not worth the hassle...
bence - September 8, 2009 at 5:52am
I had the same problem, but it works with the 0.7 redsnow
paul - August 9, 2009 at 1:02am
getting everything but no internet...error says i am not connected to a cellular data service.....but I am. i use sim with my samsung eternity for internet on att....HELP.....IVE RAN THIS PROGRAM 5 TIMES.
Mike - August 6, 2009 at 5:55am
Not happy here. After running all my Apple app icons disappeared including the ones in the dock. Stick to PWNAGE.
Raya - August 5, 2009 at 5:06pm
My iphone is now on DFU mode and its \"waiting to reboot\". How long should this normaly take? Mine is stuck here for like 5 minutes.What do i do?
faxao - August 5, 2009 at 5:15pm
in case your iPhone does not reboot in some 20 secs you have to unplug from the USB cable and immediately plug it in again: this trick did work for me.
RayaI - August 5, 2009 at 5:25pm
Its not working, Its still stuck. :S I removed it from the usb for 1 second, and plugged it back again.
faxao - August 5, 2009 at 5:30pm
do not worry.....go back again and redo the whole procedure from the beginning (iPhone in DFU, update the firmware to the 3.0 and go through the redsn0w 0.8 again)...the second time did work for me
rossb - August 17, 2009 at 6:10pm
As faxao said - unplugging from the USB then immediately plugging it back in worked for me as well. Whew! I was worried there for a second!!! Thanks faxao!
airwalker - August 29, 2009 at 5:59pm
Same thing here. After redsn0w got stucked with \"Rebooting\" iPhone 2G, a quick disconnect and reconnect of the USB cable did the job :-) Ufff...
jc - September 15, 2009 at 10:44am
unplug your usb cable from the mac and then plug back in. that should reinitiate the boot process.
Jason - January 10, 2010 at 1:43am
I got stuck too at \"Waiting for reboot.\" Taking it out of the dock and then right back in got it moving fine.
Raya - August 4, 2009 at 7:04pm
When i choose the firmware, It says \"Unable to recognize specified ipsw\" HELP!
faxao - August 5, 2009 at 2:28am
download again the appropriate firmware and check that the file has got the .ipsw format (use explorer or firefox browser not safari).....it should work
faxao - July 28, 2009 at 3:58am
It worked like a charm on my iPhone 2G fw 1.1.4 upgraded to 3.0. The only problem I had was related to the reboot of the phone during the redsn0w procedure. I had to detach and reattach immediately the phone from the USB cable (connected to my Mac) and this did the trick ! Thanks
iFlicks - August 30, 2009 at 8:16pm
Unplugging and plugging back in at reboot worked!
squidge - July 25, 2009 at 8:28pm
ok, I did the unlock through redsnow and I can make calls but why can\'t I access the web? It says I don\'t have a cellular data service. I have the following in my network settings: idata.o2.co.uk username: vertigo the password is hidden but I\'m sure this is what it had before so how come it\'s not working? I\'m with O2 (carphone warehouse) but I just have a sim through them and I got the iphone from my brother who unlocked it for me. any suggestions as to how I can get my internet access back - I pay monthly (contract) and have internet as free with the deal I manage to get.
squidge - July 25, 2009 at 8:51pm
ok - got it. if you don\'t have an iphone internet tariff then you have to change the idata.02.co.uk to mobile.o2.co.uk works now. phew... only took several hours to update to v3.0, lol :-)
Prev2 of 0Next