An App That Can Save Lives

An App That Can Save Lives

Posted September 20, 2010 at 11:20pm by iClarified · 2 comments · Add Comment
Aber1Kanobee - September 20, 2010 at 11:44pm
Should add that it requires 4.1+
Tom Vanimox - September 21, 2010 at 1:13am
maybe cydia's backwards compatibility tweak will allow it to work... Then again backward compatibility makes newer iphones run older apps, maybe itll work vice-versa... I want 4.1 jailbreak sooo bad! That games thing looks cool!
Prev 1 of 1 Next
Add Comment
Would you like to be notified when someone replies or adds a new comment?
Yes (All Threads)
Yes (This Thread Only)
No
You must login or register to add a comment...