Users Running Old Apple Software Will Soon Need to Upgrade to Change Their Payment Information

Users Running Old Apple Software Will Soon Need to Upgrade to Change Their Payment Information

Posted by · 3 comments · Add Comment
avaiish14 - June 28, 2018 at 5:03pm
Normally I’d be soooo angry and annoyed. But after using iOS 12 a little. I really don’t mind updating to it. Still I don’t want to be forced like this but I don’t mind updating to 12. But I don’t want to update my older phone to 11 ?
dvxaznsensationxvb - June 28, 2018 at 7:06pm
Can't you just go through Safari on an older iOS to update it and it's encrypted SSL from their servers already?
wuwinso - June 29, 2018 at 9:49am
It’s not like you could update any device thats still under iOS 4.3.5 or earlier to iOS 11 anyway... I dont think many ppl will be affected by this, maybe some ipod touch 1 or ipad 1 users if theres any :D
Prev1 of 1Next