December 9, 2022
How to Jailbreak Your iPhone 4 Using RedSn0w (Mac) [4.3.3]

How to Jailbreak Your iPhone 4 Using RedSn0w (Mac) [4.3.3]

Posted May 6, 2011 at 1:58pm · 98 comments · Add Comment
LBarouf
LBarouf - April 23, 2011 at 1:19pm
Mine won't jailbreak. I run version 4.3.2, updated using the method explained above. I do not really care for unlock at this moment. I run baseband version 02.10.04. Right now, besides the faulty signal strength indicator (never show anything but 1 bar) everything runs fine on my phone. Once I try to run RedSn0w, it gives me an unexpected error. If I put it in DFU mode manually before running the tool, it says it's pushing limerain to the phone, then give me an unexpected error again. What is wrong? Anyone else running in the same error? thanks for any tips.
frustrated
frustrated - May 27, 2011 at 5:31am
Dude, I have the exact same problem except I'm iOS 4.3.3. Really need some help ASAP. Please and thanx.
Jay
Jay - April 22, 2011 at 1:48pm
Anyone else cannot restore 4.3.2 on their phone? I'm trying to upgrade from 4.2.1 to 4.3.2 even if I try full restore from iTunes, or custom restore, or DFU, I always get a damn error 1013. Any ideas?
Az
Az - April 23, 2011 at 5:34am
I have the same problem.. What do we do? Someone help..
Jay
Jay - April 23, 2011 at 9:56am
The weird part, is even damn tinyumbrella fix does not work, nor a full iTunes restore. Scary... I'm tempted to call apple care at this point, could they know the phone was jailbroken before? The phone won't even boot!!!
Dairel
Dairel - April 23, 2011 at 10:25pm
check this out, it'll fix ya right up
Dairel
Dairel - April 23, 2011 at 10:26pm
http://www.redmondpie.com/fix-itunes-error-1013-when-updating-iphone-4-to-ios-4.2.1/
Jay
Jay - April 23, 2011 at 10:49pm
Thanks Daniel, much appreciated. Unfortunately, my host file is backed up, and no entry to apple (I hate when software force name resolution). That didn't do it. To add a twist to the story, I have 2 iPhones. I plugged my older iPhone, and iTuns still complained that a phone in restore mode was connected! iTunes actually displayed 2 phones connected to my dismay. Something is definitely going on. Ghost connection? New Apple "security feature" ?
Andrew
Andrew - April 21, 2011 at 3:34am
after jailbreaking i still have the no signal cosmetic issue, but afiter i install the ultrasn0w fix, my mms stopped working. Any fix for the fix lol?
CrazyMex
CrazyMex - April 20, 2011 at 9:21pm
I tried restoring with the IPSW file and it keeps telling me iPhone could not be restored. tried restoring with iTunes and I get the same message. Now my phone is on restore mood and I can't get out of it.
Loi
Loi - April 21, 2011 at 4:52pm
* Open Finder * Hold down COMMAND + SHIFT keys and press ‘G’ * Enter “/private/etc/” in the field and press “Go” * Find “hosts” file in the directory * Drag the file to your desktop * Open it in text editor * Remove the line that has gs.apple.com entirely or put a # at the beginning of it to comment it out * Save the file * Drag it back to the /private/etc/ folder. * You’d need to enter your username and password to authenticate the move
Crazymex
Crazymex - April 21, 2011 at 7:40pm
Loi, I got all the way up to remove gs.apple.com and it does not allow me to save it. It gives me the following message. To view or change permissions, select the item in the Finder and choose File > Get Info. I chose info and changed the permissions but it still does not allow me to save the file. Any ideas. Thanks
Justin
Justin - April 20, 2011 at 4:14pm
After doing the JB I now have No Service, I have gone back to stock for now. Does anyone know why the JB works perfectly on some devices and not others?
Justin
Justin - April 20, 2011 at 4:36pm
I seemed to have fixed my own issue. Restored back to stock. Turned off sim pin and activated phone on Itunes. Then did Redsnow JB and restored last backup(Itunes sync) and now all working!
Kraig
Kraig - April 20, 2011 at 2:02am
I can't get the IPSW to work at all. RedSn0w isn't recognizing it one bit.
joseph
joseph - April 19, 2011 at 7:49pm
I've done the jailbreak, but cannot get cellular network, I've already restore from my backup and still does not have the network ATT
paul
paul - April 19, 2011 at 7:27pm
The WiFi issues are still there... and by issues i mean WiFi doesn't work
Drew
Drew - April 19, 2011 at 6:54pm
Does anyone know if this will work for the Verizon iPhone (version 4.2.7)? If not, any news when a jailbreak will be released for it?
rbs2000
rbs2000 - April 19, 2011 at 12:38pm
does the 4.3.2 updates ur baseband ? I am on 4.10.0 right now.. Not like I care I am on att . Thank you DEV TEAM you are awesome... You guys are making a=our devices worth having them,I just can't imagine an Iphone without a jailbreak,Its useless. Thank you
You must login or register to add a comment...
Add Comment
Would you like to be notified when someone replies or adds a new comment?
Yes (All Threads)
Yes (This Thread Only)
No