September 26, 2022
How to Jailbreak Your iPhone 3GS Using PwnageTool (Mac) [4.3.3]

How to Jailbreak Your iPhone 3GS Using PwnageTool (Mac) [4.3.3]

Posted May 6, 2011 at 3:06pm · 91 comments · Add Comment
Mikey
Mikey - December 1, 2012 at 10:53am
Followed this three times and no go. "this device is not elligable for requested rebuild?
Brad
Brad - December 11, 2011 at 8:52pm
I have 3 iphones, all 3 are 3gs. 3gs FW 4.0 (NOT 4.0.1) bb 05.13.04 bl 6.4 model MC640 bootrom 359.3.2 (unfortunately) JB jailbreakme UL ultrasn0w 3gs FW 4.0.1 bb 05.13.04 bl 6.4 model MC136 bootrom 359.3.2 (unfortunately) JB jailbreakme UL ultrasn0w 3gs FW 4.0.1 bb 05.13.04 bl 6.4 model MC133 bootrom 359.3.2 (unfortunately) JB jailbreakme UL ultrasn0w I have tried updating to 4.3.3 doing the following: pwnage tool to create custom ipsw. Enter DFU, hold option, click restore, select custom ipsw, Extracting, verifying with apple.... then I get this message... "this device isnt eligible for the requested build" I have tried editing the hosts file, to no avail. My question is this. I want to upgrade all 3 phones to the most recent FW that is UNTETHERED JB, and must be unlockable as I use T-mobile. What FW do I use, and what steps do I need to take. I have updated, JB, and unlocked phones before, but never had the message stated above. My eyes are crossed from reading and searching, so I really need some help on this one. Thank you in advance for you help. It is greatly appreciated. I use a MAC OS X 10.6.8 iTunes 10.5
chelsea
chelsea - November 19, 2011 at 12:43am
ive done this several times (with my iphone 3gs firmware 4.2.1) and each time itunes says firmware not compatible at the end. im so disappointed- ive been trying EVERYTHING... for WEEKS :( "i really dont wanna let it beat me like that wireless router did" -the office anyone?
seattlepunk
seattlepunk - November 26, 2011 at 12:24am
Getting the same error: The iPhone "iPhone" could not be restored because firmware file is not compatible. Tried this with both Activate checked and then not-checked.
Rose
Rose - June 25, 2011 at 9:54am
My phone wasn't working right, so I restored it to factory settings. Then I went through all these steps, and when I select the custom firmware created by Pwnage tool, iTunes says the firmware file is not compatible? I tried doing it again and unchecking "Activate" but the same thing happens. Help?
Tang
Tang - June 23, 2011 at 1:52pm
When I click on the links to download the PwnageTool_4.3.3, one says page not found, the other one downloaded a .torrent format document, which I couldn't open. I've used PwnageTool before it wasn't like this before. Something amiss with the links? Thanks.
anoop
anoop - May 26, 2011 at 5:18am
Hi, I did all the steps mentioned above , when i went to restore my phone it says that the " iphone cannot be restored as the firmware file is not compatible " i have already updated to the official 4.3.3 and it is stuck in the activate screen ! kindly help me out on this . i am not able to restore to the custom firmware and jailbreak it . help is much appreciated guys ! ty
Qiz
Qiz - May 25, 2011 at 6:48am
Hello, What size of the root partition should I use, minimum? Thanks in advance
Novaboyjp
Novaboyjp - May 25, 2011 at 2:53am
Hey, thanks! This worked brilliantly. Now running 4.3.3 on my 3Gs, kept old baseband of 5.13.04 Great work guys!!
Gorye
Gorye - May 23, 2011 at 3:22am
Once I get to the "Browse for IPSW" step, early on, and select the restore bundle, I get a "wrong bundle selected" message and can go no further. THanks for your help in advance.
Tomas
Tomas - May 16, 2011 at 4:07pm
I think Restoring bug is because cydia was in the folder when I did backup. Anyone has this problem please let me know. I
You must login or register to add a comment...
Add Comment
Would you like to be notified when someone replies or adds a new comment?
Yes (All Threads)
Yes (This Thread Only)
No