August 12, 2022
O iPhone Dev-Team libera o desbloqueio do iOS 4.2.1 para o iPhone 3G e 3GS

O iPhone Dev-Team libera o desbloqueio do iOS 4.2.1 para o iPhone 3G e 3GS

Posted November 28, 2010 at 4:31pm by iClarified · 140990 views
EnglishPortuguese (Brazil)
O iPhone Dev-Team liberou o desbloqueio de operadoras do iOS 4.2.1 para o iPhone 3G e o iPhone 3GS.

Por favor leia o anúncio com muito cuidado...

-----
Hoje temos o prazer de anunciar o nosso desbloqueio gratuito de operadoras para os proprietários iPhone3G/3GS com a baseband até 05.13.04. O desbloqueio para a baseband explorou o comando AT + XAPP, graças a uma falha descoberta inicialmente pelo @sherif_hashim (@Oranav também encontrou esta falha). Então, qual a brecha que estamos explorando hoje, desde que a Apple fechou o a brecha AT + XAPP? Bem, nós estamos explorando exatamente a mesma brecha!

Primeiramente, acontece que o firmware 3.2.2 do iPad contém a baseband versão 06.15.00 permanecendo vulnerável ao AT+XAPP. A baseband do iPad foi elaborada exatamente para o mesmo chip de baseband do iPhone 3G/3GS - eles são totalmente compatíveis! Alguns de nós têm rodado a 06.15 por semanas em nossos iPhone no preparo desse lançamento.

Desde que a versão 06.15 é mais recente que a 05.14 ou 05.15 (onde o AT+XAPP se foi), qualquer um preso a essas versões podem simplesmente atualizar para a versão 06.15 para desbloquear de novo! Felizmente para nós, a Apple *ainda* fornece o firmware 3.2.22 do iPad com esta baseband vulnerável diretamente de seus próprios servidores. (Pegue-o agora, antes que eles derrubem-no!)

Nós estivemos ocupados atualizando tanto o PwnageTool e o redsn0w para fazer a atualização da baseband tão simples quanto possível.

1. Primeiramente é o “PwnageTool 4.1.3 Unlock Edition”. Ele tem uma caixa de diálogo especial que pergunta se você quer atualizar para a baseband do iPad. Você ja deve ter o IPSW 3.2.2 do iPad no seu computador (veja acima link)…. então aponte ela na PwnageTool (ou deixe-a encontrá-la sozinha se você estiver no modo "simples").
2. Diretamente após a PwnageTool 4.1.3 disponibilizada, o repositório oficial do ultrasn0w http://repo666.ultrasn0w.com será atualizado com o ultrasn0w 1.2, que cobre o iPhone 4 com baseband 01.59.00 e os iPhone 3G/3GS com basebands 04.26.08, 05.11.07, 05.12.01, 05.13.04 e agora 06.15.00.
3. Finalmente, nos iremos lançar uma atualização do redsn0w hoje para aqueles que sem Macs e não podem rodar a PwnageTool. O novo redsn0w dará a opção para atualizar sua baseband para 06.15 também.

AVISO — FAÇA ISSO POR SUA CONTA E RISCO. POR FAVOR COMPREENDA AS CONSEQUENCIAS DA ATUALIZAÇÃO PARA A 06.15.
1. Não existe uma forma de voltar para uma versão mais antiga a partir da 06.15, e não existe como esconder a versão da Apple. Você estará violando sua garantia de uma forma muito óbvia.
2. Se algumas versões futuras de basebands forem lançadas com correções críticas, você não poderá atualizar para ela se ela permanece abaixo da sequencia 05.xx (então, novamente, você não deve atualizar pra ela se você quisesse manter seu destravamento de qualquer forma).
3. Instalando o FW 4.2.1 juntamente com a baseband 06.15 em seu iPhonevocê nunca vai ser capaz de restaurar a firmware stock (ele irá falhar). Você precisará restaurar apenas IPSWs personalizados (novamente, se você for um destravador, já deve estar fazendo isso).

Certamente, não atualize para a versão 06.15 se você não precisar! Faça isso somente se você precisa do desbloqueio e está preso nas versões 05.14 ou 05.15, e você está disposto a assumir os riscos acima.

Essa PwnageTool também contem um pacote 4.2.1 para os proprietários de iPhone3G… para tudo, ainda é apenas para a 4.1. Se você tem um iPhone3GS com uma bootrom antiga, o novo redsn0w irá gerenciar a 4.2.1 pra você (de fato, ele abrange a versão 4.2.1 para todos os dispositivos, embora alguns deles permanecem tethered na 4.2.1 até que o @comex possa trabalhar em alguma mágina de untethering). Usuários de iPhone3GS com bootroms antigas que querem ir para a 4.2.1 não devem usar essa PwnageTool! Atualize primeiramente para 4.2.1 stock, então use o próximo release do redsn0w para atualizar sua baseband.
----

Estaremos postando tutorias para ajudar vocês com essas novas ferramentas o mais rapidamente possível.

Você pode baixar a PwnageTool 4.1.3 aqui.

Leia Mais


O iPhone Dev-Team libera o desbloqueio do iOS 4.2.1 para o iPhone 3G e 3GS
Add Comment
Would you like to be notified when someone replies or adds a new comment?
Yes (All Threads)
Yes (This Thread Only)
No
iClarified Icon
Notifications
Would you like to be notified when we post a new Apple news article or tutorial?
Yes
No
You must login or register to add a comment...
Thomass
Thomass - November 29, 2010 at 5:07am
I have iPhone 4 4.01 BB 1.59 and on CYDIA SAYS THERES UPGRADE FOR ULTRASN0W should I UPGRADE or leave it or what???????
andrew
andrew - November 29, 2010 at 1:25am
I have a 3gs running 4.1 on baseband 05.14.02. as i understand it. there is currently no unlock for this baseband. if thats the case how can i change my baseband?? im dying for an unlock to use my iphone!! do i need to upgrade to 4.2.1 which will change my baseband?? I appreciate all your help and good work. your tech skills are above and beyond mine!!!
luisdk
luisdk - November 29, 2010 at 2:32am
Iphone 3g 4.1 baseband 05.14.02, just unlocked, use redsn0w with the option of Ipad baseband , use Firmware 4.2.1, after process the phone remains with Firmware 4.1, baseband 6.15.00, after this ,unlock via Cydia with Ultrasn0w as normal, thats it.
Nels
Nels - December 7, 2010 at 7:44am
Will I be able to downgrade back to f/w 4.1 after I updated the baseband 06.15.00 in f/w 4.2.1?
Bada-Bing
Bada-Bing - December 14, 2010 at 6:12pm
yup....u have too...thats what i did...updated 4.1 to 4.2.1 which gave me the 06.15.00 baseband and downgraded back to 4.2.1 which still leaves my phone with 06.15.00 baseband...!
13 More Comments
Recent. Read the latest Apple News.
RECENT
Tutorials. Help is here.
TUTORIALS
Deals. Save on Apple devices and accessories.
DEALS