Swift 3.0 to be Released Later This Year, Will Not Be Source Compatible With Swift 2.2

Swift 3.0 to be Released Later This Year, Will Not Be Source Compatible With Swift 2.2

Posted by · 5 comments · Add Comment
stupido grande - May 8, 2016 at 6:27pm
LOL, this is what's wrong with society. No backward compatibility. Imagine if electric companies every few months change wall socket design, etc. OK, sure technology changes but come on, offer some kind of compatibility, don't just force us to keep upgrading and spending money because share holders force you to. Ridiculous.
CSci - May 8, 2016 at 11:23pm
I don't think you understand the topic... You don't pay for swift.
Barrett - May 9, 2016 at 4:18am
I think he is referring to the cost of time and developer resources it adds to maintain a project in swift.
YourFault - May 9, 2016 at 12:41pm
It's a new language, changes will be made to it. If you didn't want to deal with these type of things you should've used Objective-C. No one to blame but yourself.
Dominik Pich - May 9, 2016 at 1:01pm
I so agree.. this was SO predictable. companies/individuals that decided to use swift had to know and be ready to change!
Prev1 of 1Next